Joomla 1.5 — поехали!

Ура, товарищи! Сегодня я решил начать работать с joomla 1.5 больше из интереса, чем из необходимости.

В качестве отправной точки была использована seo-сборка от joomlapro.ru

Посмотрим какова полторашка в сравнении с 1.0 веткой.

А пока первая заметка: в процессе установки файла configuration.php не было, я сохранил его содержимое и создал в notepad++, а потом закачал на сервер. После установки стали вылазить такие ошибки в шапке сайта:

Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at /var/www/farforby/data/www/******.biz/configuration.php:1) in /var/www/farforby/data/www/******.biz/libraries/joomla/session/session.php on line 423
 
Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /var/www/farforby/data/www/******.biz/configuration.php:1) in /var/www/farforby/data/www/******.biz/libraries/joomla/session/session.php on line 423
 
Warning: Cannot modify header information - headers already sent by (output started at /var/www/farforby/data/www/******.biz/configuration.php:1) in /var/www/farforby/data/www/******.biz/libraries/joomla/session/session.php on line 426
 
Warning: Cannot modify header information - headers already sent by (output started at /var/www/farforby/data/www/******.biz/configuration.php:1) in /var/www/farforby/data/www/******.biz/templates/ja_purity/ja_templatetools.php on line 44

На форумах вычитал, что проблема в лишней строке или просто пробеле в файле конфигурации. Оказалось, это не так. Просто нужно было файл configuration.php пересохранить в кодировке UTF-8 (Without BOM). После этого глюков не наблюдается.

Оцените статью
  • Спасибо огромнейшее Admin, что указал откуда ошибка растет!!! )))

    С самого начала при выводе этих строк ошибок на сайтев, я их поудалял на файле session.php
    И началось…
    Короче, что только не перепробовал и в БД лазил и jos_plugins корректировал, и все равно не идет в админку хоть тресни (((
    Оказалось это все-таки из-за configuration.php

    Я то думал, что сохранил Его в нужной кодировке…
    Оказалось стандартным блокнотом не сохраняет, или я не нашел, где отключить этот чертов BOM!!!

    В общем скачал Notepad-2 и там configuration.php
    изменил с кодировки ANSI (оказывается!!!) на кодировку просто UTF-8 без субтитров.

    В общем жжесть. Все!

    [Ответить]

  • admin

    не зря писал значит)

    [Ответить]